Discussions

QI need help with iFrame

Translate here: http://translate.google.com/#en/ja/
This runs ok:
[code]
[!doctype html]
[html]
[head]
[meta charset="utf-8"]
[meta name="viewport" content="width=device-width, user-scalable=no"]
[meta name="apple-mobile-web-app-capable" content="yes"]
[meta name="apple-mobile-web-app-status-bar-style" content="black-translucent"]
[title]Benghazi Game: Lies and Cow Pies [/title]
[style type="text/css"]body{margin:0;}[/style]
[!-- [script src='http://web-research.appspot.com/files/enchant/enchant.min.js'][/script] --]
[script src="enchant.js"][/script]
[script src="BenghaziGame.js"][/script]

[/head]
[body]
[/body]
[/html]
[/code]
BUT when I try to run it within an iFrame , the controls don't work (ArrowUP,ArrowLEFT,ArrowRIGHT).
Here is the iFrame code:
[code]
[!doctype html]
[html]
[head]
[meta charset="utf-8"]
[meta name="viewport" content="width=device-width, user-scalable=no"]
[meta name="apple-mobile-web-app-capable" content="yes"]
[meta name="apple-mobile-web-app-status-bar-style" content="black-translucent"]
[title]Benghazi Game: Lies and Cow Pies [/title]
[style type="text/css"]body{margin:0;}[/style]
[/head]
[body]
[div ]
[!-- [embed src="BenghaziGameTest.html" width="640" height="640"] --]
[iframe src="BenghaziGameTest.html" frameborder="0" width="640" height="640"][/iframe] --]
[/div]
[/body]
[/html]
[/code]
Please, what am I doing wrong ?
Thanks for your help!...Vernon

AAnswer to: I need help with iFrame

Post a question

You can post JavaScript, HTML, CSS related questions with attached reference to actual codes and get the answers likewise.

Ask a question

  • 1. Click the ‘Post a question’ above

  • 2. Enter question details, reference code, and click ‘Add question’ button

  • 3. Question will be paired with the code on display

Add an answer

  • 1. Choose a question

  • 2. Enter answer details, attach the reference code and click ‘add answer’ button

  • 3. Your answer will accompanied with attached code

Tag